summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/yahoo/ui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/protocols/yahoo/ui/CMakeLists.txt')
-rw-r--r--kopete/protocols/yahoo/ui/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/kopete/protocols/yahoo/ui/CMakeLists.txt b/kopete/protocols/yahoo/ui/CMakeLists.txt
new file mode 100644
index 00000000..4da1fb8a
--- /dev/null
+++ b/kopete/protocols/yahoo/ui/CMakeLists.txt
@@ -0,0 +1,30 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### kopeteyahooui (static) ####################
+
+tde_add_library( kopeteyahooui STATIC_PIC AUTOMOC
+ SOURCES
+ yahooadd.ui yahooeditaccountbase.ui yahooinvitelistbase.ui
+ yahooinvitelistimpl.cpp empty.cpp yahooverifyaccountbase.ui
+ yahoostealthsetting.ui yahoowebcamdialog.cpp yahoogeneralinfowidget.ui
+ yahoouserinfodialog.cpp yahooworkinfowidget.ui
+ yahoootherinfowidget.ui
+)