summaryrefslogtreecommitdiffstats
path: root/krfb/srvloc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'krfb/srvloc/Makefile.am')
-rw-r--r--krfb/srvloc/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/krfb/srvloc/Makefile.am b/krfb/srvloc/Makefile.am
new file mode 100644
index 00000000..162e2062
--- /dev/null
+++ b/krfb/srvloc/Makefile.am
@@ -0,0 +1,17 @@
+METASOURCES = AUTO
+
+# Code
+noinst_LTLIBRARIES = libsrvloc.la
+
+libsrvloc_la_SOURCES = kserviceregistry.cpp uuid.cpp \
+ kinetinterface.cpp kinetinterfacewatcher.cpp \
+ getifaddrs.cpp
+
+libsrvloc_la_LIBADD = $(LIB_QT) $(LIB_KDECORE) $(LIB_SLP)
+libsrvloc_la_LDFLAGS = $(all_libraries) -no-undefined
+noinst_HEADERS = kserviceregistry.h uuid.h \
+ getifaddrs.h kinetinterface.h kinetinterfacewatcher.h
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+