summaryrefslogtreecommitdiffstats
path: root/akregator/src/mk4storage/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-14 19:26:10 +0200
commit3e868d844c44aab62fd1324e52872afd1f706cd3 (patch)
treeb3c06badd9b8f004ae92024d53c8bf15b8849cf0 /akregator/src/mk4storage/CMakeLists.txt
parent9d2dbcebff2529124b4a522d3714b308548ee9ec (diff)
downloadtdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.tar.gz
tdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 0d3043b6308af148da06ac14c53defc4b1e7e138)
Diffstat (limited to 'akregator/src/mk4storage/CMakeLists.txt')
-rw-r--r--akregator/src/mk4storage/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/akregator/src/mk4storage/CMakeLists.txt b/akregator/src/mk4storage/CMakeLists.txt
index c229d6ecf..a1c786134 100644
--- a/akregator/src/mk4storage/CMakeLists.txt
+++ b/akregator/src/mk4storage/CMakeLists.txt
@@ -27,7 +27,12 @@ link_directories(
##### other data ################################
-install( FILES akregator_mk4storage_plugin.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE akregator_mk4storage_plugin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR akregator-desktops
+)
+
install( FILES mk4config.kcfg DESTINATION ${KCFG_INSTALL_DIR} )