summaryrefslogtreecommitdiffstats
path: root/certmanager/conf/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /certmanager/conf/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'certmanager/conf/Makefile.am')
-rw-r--r--certmanager/conf/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/certmanager/conf/Makefile.am b/certmanager/conf/Makefile.am
new file mode 100644
index 000000000..f58c20c77
--- /dev/null
+++ b/certmanager/conf/Makefile.am
@@ -0,0 +1,26 @@
+AM_CPPFLAGS = -DLIBKLEOPATRA_NO_COMPAT -I$(srcdir)/../lib -I$(srcdir)/../lib/ui -I../lib/ui \
+ -I$(top_srcdir)/libkdenetwork $(GPGME_CFLAGS) $(all_includes)
+
+METASOURCES = AUTO
+
+# the stuff that gets compiled into kleopatra
+noinst_LTLIBRARIES = libconf.la
+libconf_la_SOURCES = configuredialog.cpp
+
+kde_module_LTLIBRARIES = kcm_kleopatra.la
+
+kcm_kleopatra_la_SOURCES = dirservconfigpage.cpp \
+ appearanceconfigpage.cpp \
+ appearanceconfigwidgetbase.ui \
+ appearanceconfigwidget.cpp \
+ dnorderconfigpage.cpp
+
+kcm_kleopatra_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_kleopatra_la_LIBADD = ../lib/libkleopatra.la $(LIB_KDEUI)
+
+kde_services_DATA = \
+ kleopatra_config_dirserv.desktop \
+ kleopatra_config_appear.desktop \
+ kleopatra_config_dnorder.desktop
+
+dirservconfigpage.lo: ../lib/ui/directoryserviceswidgetbase.h