summaryrefslogtreecommitdiffstats
path: root/kaddressbook/editors/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /kaddressbook/editors/protocols/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kaddressbook/editors/protocols/CMakeLists.txt')
-rw-r--r--kaddressbook/editors/protocols/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/kaddressbook/editors/protocols/CMakeLists.txt b/kaddressbook/editors/protocols/CMakeLists.txt
index 87e3e32c8..d93b0cf2e 100644
--- a/kaddressbook/editors/protocols/CMakeLists.txt
+++ b/kaddressbook/editors/protocols/CMakeLists.txt
@@ -9,9 +9,12 @@
#
#################################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
icqprotocol.desktop aimprotocol.desktop ircprotocol.desktop smsprotocol.desktop
gaduprotocol.desktop jabberprotocol.desktop yahooprotocol.desktop
msnprotocol.desktop groupwiseprotocol.desktop meanwhileprotocol.desktop
skypeprotocol.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/kaddressbook )
+ DESTINATION ${SERVICES_INSTALL_DIR}/kaddressbook
+ PO_DIR kaddressbook-desktops
+)