summaryrefslogtreecommitdiffstats
path: root/kaddressbook/printing/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kaddressbook/printing/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kaddressbook/printing/Makefile.am')
-rw-r--r--kaddressbook/printing/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kaddressbook/printing/Makefile.am b/kaddressbook/printing/Makefile.am
new file mode 100644
index 000000000..86e7d2793
--- /dev/null
+++ b/kaddressbook/printing/Makefile.am
@@ -0,0 +1,32 @@
+INCLUDES = -I$(top_srcdir) -I$(top_builddir)/kaddressbook -I$(top_srcdir)/kaddressbook \
+ -I$(top_srcdir)/kaddressbook/details -I$(top_srcdir)/kaddressbook/common \
+ -I$(top_builddir)/kaddressbook/common $(all_includes)
+
+noinst_LTLIBRARIES = libprinter.la
+
+libprinter_la_SOURCES = \
+ detailledstyle.cpp \
+ ds_appearance.ui \
+ kabentrypainter.cpp \
+ mikesstyle.cpp \
+ printingwizard.cpp \
+ printprogress.cpp \
+ printstyle.cpp \
+ selectionpage.cpp \
+ stylepage.cpp \
+ printsortmode.cpp
+libprinter_la_COMPILE_FIRST = $(top_builddir)/kaddressbook/common/kabprefs_base.h
+
+EXTRA_DIST = \
+ detailledstyle.cpp detailledstyle.h kabentrypainter.h \
+ mikesstyle.cpp mikesstyle.h \
+ printingwizard.cpp printingwizard.h \
+ printprogress.cpp printprogress.h \
+ printstyle.cpp printstyle.h rbs_appearance.ui.h \
+ selectionpage.cpp selectionpage.h \
+ stylepage.cpp stylepage.h
+
+libprinter_la_METASOURCES = AUTO
+
+previewdir = $(kde_datadir)/kaddressbook/printing
+preview_DATA = detailed-style.png mike-style.png