summaryrefslogtreecommitdiffstats
path: root/kioslaves/imap4/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /kioslaves/imap4/CMakeLists.txt
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kioslaves/imap4/CMakeLists.txt')
-rw-r--r--kioslaves/imap4/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/kioslaves/imap4/CMakeLists.txt b/kioslaves/imap4/CMakeLists.txt
deleted file mode 100644
index adb628c35..000000000
--- a/kioslaves/imap4/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-tde_import( libkmime )
-
-include_directories(
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}/libemailfunctions
- ${CMAKE_SOURCE_DIR}/libkmime
- ${CMAKE_SOURCE_DIR}/libtdepim
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### other data ################################
-
-install( FILES
- imap4.protocol imaps.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
-
-
-##### kio_imap4 (module) ########################
-
-tde_add_kpart( kio_imap4
- SOURCES
- imapcommand.cc imaplist.cc mailaddress.cc mimeheader.cc
- rfcdecoder.cc imap4.cc imapinfo.cc imapparser.cc
- mailheader.cc mimehdrline.cc mimeio.cc
- LINK emailfunctions-static kmime-shared kio-shared ${SASL_LIBRARY}
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)