summaryrefslogtreecommitdiffstats
path: root/kioslaves/sieve/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kioslaves/sieve/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslaves/sieve/Makefile.am')
-rw-r--r--kioslaves/sieve/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kioslaves/sieve/Makefile.am b/kioslaves/sieve/Makefile.am
new file mode 100644
index 000000000..830c8258e
--- /dev/null
+++ b/kioslaves/sieve/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES= -I$(srcdir)/../.. -I$(srcdir)/.. $(all_includes)
+
+kde_module_LTLIBRARIES = kio_sieve.la
+
+kio_sieve_la_SOURCES = sieve.cpp
+kio_sieve_la_LIBADD = $(LIB_KIO) $(SASL2_LIBS)
+kio_sieve_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+noinst_HEADERS = sieve.h
+
+kdelnk_DATA = sieve.protocol
+kdelnkdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_sieve.pot