summaryrefslogtreecommitdiffstats
path: root/kitchensync/libqopensync/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kitchensync/libqopensync/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kitchensync/libqopensync/Makefile.am')
-rw-r--r--kitchensync/libqopensync/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kitchensync/libqopensync/Makefile.am b/kitchensync/libqopensync/Makefile.am
new file mode 100644
index 000000000..2e12df6ca
--- /dev/null
+++ b/kitchensync/libqopensync/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = -I$(top_srcdir)/kitchensync/src \
+ -I$(top_srcdir)/kitchensync \
+ -I$(top_srcdir) \
+ $(OPENSYNC_CFLAGS) \
+ $(OPENSYNCENGINE_CFLAGS) \
+ $(all_includes)
+
+lib_LTLIBRARIES = libqopensync.la
+
+libqopensync_la_SOURCES = callbackhandler.cpp conversion.cpp engine.cpp environment.cpp filter.cpp group.cpp \
+ member.cpp plugin.cpp result.cpp syncmapping.cpp syncupdates.cpp \
+ syncchange.cpp
+libqopensync_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -no-undefined
+libqopensync_la_LIBADD = $(LIB_KDEUI) $(OPENSYNC_LIBS) $(OPENSYNCENGINE_LIBS)
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/libqopensync.pot