summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/kmail/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kontact/plugins/kmail/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kontact/plugins/kmail/Makefile.am')
-rw-r--r--kontact/plugins/kmail/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/kontact/plugins/kmail/Makefile.am b/kontact/plugins/kmail/Makefile.am
new file mode 100644
index 000000000..d176693a3
--- /dev/null
+++ b/kontact/plugins/kmail/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir)/kmail -I$(top_builddir)/kmail \
+ -I$(top_srcdir)/libkdepim \
+ -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_kmailplugin.la kcm_kmailsummary.la
+
+libkontact_kmailplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_kmailplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la $(top_builddir)/libkcal/libkcal.la $(LIB_KPARTS)
+
+libkontact_kmailplugin_la_SOURCES = kmail_plugin.cpp kmailIface.stub \
+ summarywidget.cpp summarywidget.skel
+
+kcm_kmailsummary_la_SOURCES = kcmkmailsummary.cpp
+kcm_kmailsummary_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries) \
+ -avoid-version -no-undefined
+kcm_kmailsummary_la_LIBADD = $(LIB_KDEUI)
+
+kmailIface_DCOPIDLNG = true
+
+summarywidget_DCOPIDLNG = true
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = kmailplugin.desktop
+
+kde_services_DATA = kcmkmailsummary.desktop
+
+kmailIface_DIR = $(top_srcdir)/kmail