summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/abbrowserconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitf4fae92b6768541e2952173c3d4b09040f95bf7e (patch)
treed8c5d93232235cd635f3310b4d95490df181ba2d /kpilot/conduits/abbrowserconduit/CMakeLists.txt
parent125c0a08265b75a133644d3b55f47e37c919f45d (diff)
downloadtdepim-f4fae92b6768541e2952173c3d4b09040f95bf7e.tar.gz
tdepim-f4fae92b6768541e2952173c3d4b09040f95bf7e.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/conduits/abbrowserconduit/CMakeLists.txt')
-rw-r--r--kpilot/conduits/abbrowserconduit/CMakeLists.txt46
1 files changed, 0 insertions, 46 deletions
diff --git a/kpilot/conduits/abbrowserconduit/CMakeLists.txt b/kpilot/conduits/abbrowserconduit/CMakeLists.txt
deleted file mode 100644
index 2459d1db9..000000000
--- a/kpilot/conduits/abbrowserconduit/CMakeLists.txt
+++ /dev/null
@@ -1,46 +0,0 @@
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
-)
-
-set(conduit_abbrowser_SRCS
- resolutionDialog.cc
- abbrowser-factory.cc
- abbrowser-setup.cc
- kabcRecord.cc
- abbrowser-conduit.cc
-)
-
-set(conduit_abbrowser_UIS
- resolutionDialog_base.ui
- kaddressbookConduit.ui
-)
-
-set(conduit_abbrowser_KCFGS
- abbrowserSettings.kcfgc
-)
-
-kde3_add_kcfg_files(conduit_abbrowser_SRCS ${conduit_abbrowser_KCFGS})
-kde3_add_ui_files(conduit_abbrowser_SRCS ${conduit_abbrowser_UIS})
-kde3_automoc(${conduit_abbrowser_SRCS})
-add_library(conduit_address SHARED ${conduit_abbrowser_SRCS})
-target_link_libraries(conduit_address kabc_file kabc)
-set_target_properties(conduit_address PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib
- PREFIX ""
-)
-
-kde3_install_libtool_file(conduit_address)
-
-install(
- TARGETS conduit_address
- LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
-)
-
-install(
- FILES abbrowser_conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
-)
-
-install(
- FILES abbrowserconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
-)
-