summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/knotes/CMakeLists.txt
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kpilot/conduits/knotes/CMakeLists.txt
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/conduits/knotes/CMakeLists.txt')
-rw-r--r--kpilot/conduits/knotes/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/kpilot/conduits/knotes/CMakeLists.txt b/kpilot/conduits/knotes/CMakeLists.txt
new file mode 100644
index 000000000..568adb427
--- /dev/null
+++ b/kpilot/conduits/knotes/CMakeLists.txt
@@ -0,0 +1,52 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+set(conduit_knotes_SRCS
+ knotes-factory.cc
+ knotes-setup.cc
+ knotes-action.cc
+)
+
+set(conduit_knotes_UIS
+ setup_base.ui
+)
+
+set(conduit_knotes_KCFGS
+ knotesconduitSettings.kcfgc
+)
+
+#set(conduit_knotes_STUBS
+# KNotesIface.h
+#)
+
+#kde3_add_dcop_skels(conduit_knotes_SRCS ${conduit_knotes_STUBS})
+#kde3_add_dcop_stubs(conduit_knotes_SRCS ${conduit_knotes_STUBS})
+
+kde3_add_kcfg_files(conduit_knotes_SRCS ${conduit_knotes_KCFGS})
+kde3_add_ui_files(conduit_knotes_SRCS ${conduit_knotes_UIS})
+kde3_automoc(${conduit_knotes_SRCS})
+
+add_library(conduit_knotes SHARED ${conduit_knotes_SRCS})
+target_link_libraries(conduit_knotes kcal)
+
+set_target_properties(conduit_knotes PROPERTIES
+ LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib
+ PREFIX ""
+)
+
+kde3_install_libtool_file(conduit_knotes)
+
+install(
+ TARGETS conduit_knotes
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES knotes-conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES knotesconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)