summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/malconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kpilot/conduits/malconduit/CMakeLists.txt
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/conduits/malconduit/CMakeLists.txt')
-rw-r--r--kpilot/conduits/malconduit/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/kpilot/conduits/malconduit/CMakeLists.txt b/kpilot/conduits/malconduit/CMakeLists.txt
new file mode 100644
index 000000000..092f340fd
--- /dev/null
+++ b/kpilot/conduits/malconduit/CMakeLists.txt
@@ -0,0 +1,48 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${MAL_INCLUDE_DIR}
+)
+
+set(conduit_mal_SRCS
+ mal-factory.cc
+ mal-setup.cc
+ mal-conduit.cc
+)
+
+set(conduit_mal_UIS
+ mal-setup_dialog.ui
+)
+
+set(conduit_mal_KCFGS
+ malconduitSettings.kcfgc
+)
+
+kde3_add_kcfg_files(conduit_mal_SRCS ${conduit_mal_KCFGS})
+kde3_add_ui_files(conduit_mal_SRCS ${conduit_mal_UIS})
+kde3_automoc(${conduit_mal_SRCS})
+add_library(conduit_mal SHARED ${conduit_mal_SRCS})
+target_link_libraries(conduit_mal ${MAL_LIBRARY})
+
+set_target_properties(
+ conduit_mal PROPERTIES
+ LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ PREFIX ""
+ INSTALL_RPATH "${MAL_LIBRARY}"
+ INSTALL_RPATH_USE_LINK_PATH true
+)
+
+kde3_install_libtool_file(conduit_mal)
+
+install(
+ TARGETS conduit_mal
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES mal_conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES malconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)
+