summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/popmail/CMakeLists.txt
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kpilot/conduits/popmail/CMakeLists.txt
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/conduits/popmail/CMakeLists.txt')
-rw-r--r--kpilot/conduits/popmail/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/kpilot/conduits/popmail/CMakeLists.txt b/kpilot/conduits/popmail/CMakeLists.txt
new file mode 100644
index 000000000..daec3c3a8
--- /dev/null
+++ b/kpilot/conduits/popmail/CMakeLists.txt
@@ -0,0 +1,43 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+set(conduit_popmail_SRCS
+ popmail-factory.cc
+ popmail-conduit.cc
+ setupDialog.cc
+)
+
+set(conduit_popmail_UIS
+ setup-dialog.ui
+)
+
+set(conduit_popmail_KCFGS
+ popmailSettings.kcfgc
+)
+
+kde3_add_kcfg_files(conduit_popmail_SRCS ${conduit_popmail_KCFGS})
+kde3_add_ui_files(conduit_popmail_SRCS ${conduit_popmail_UIS})
+kde3_automoc(${conduit_popmail_SRCS})
+add_library(conduit_popmail SHARED ${conduit_popmail_SRCS})
+
+set_target_properties(
+ conduit_popmail PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib
+ PREFIX ""
+)
+
+kde3_install_libtool_file(conduit_popmail)
+
+install(
+ TARGETS conduit_popmail
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES popmail-conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES popmail.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)