summaryrefslogtreecommitdiffstats
path: root/kresources/egroupware/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /kresources/egroupware/Makefile.am
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kresources/egroupware/Makefile.am')
-rw-r--r--kresources/egroupware/Makefile.am73
1 files changed, 0 insertions, 73 deletions
diff --git a/kresources/egroupware/Makefile.am b/kresources/egroupware/Makefile.am
deleted file mode 100644
index a3effa7fb..000000000
--- a/kresources/egroupware/Makefile.am
+++ /dev/null
@@ -1,73 +0,0 @@
-INCLUDES = -I$(top_srcdir)/libical/src/libical \
- -I$(top_srcdir)/libical/src/libicalss \
- -I$(top_builddir)/libical/src/libical \
- -I$(top_builddir)/libical/src/libicalss \
- -I$(srcdir)/versit -I$(top_srcdir)/ \
- -I$(top_srcdir)/knotes \
- -I$(top_builddir)/kaddressbook \
- -I$(top_builddir)/kaddressbook/common \
- -I$(top_srcdir)/kaddressbook/common \
- -I$(top_builddir)/kresources/egroupware \
- $(all_includes)
-
-noinst_HEADERS = kabc_resourcexmlrpcconfig.h kcal_resourcexmlrpcconfig.h \
- knotes_resourcexmlrpcconfig.h
-
-noinst_LTLIBRARIES = libegwcommon.la
-libegwcommon_la_SOURCES = xmlrpciface.cpp synchronizer.cpp debugdialog.cpp
-
-lib_LTLIBRARIES = libkabc_xmlrpc.la libkcal_xmlrpc.la libknotes_xmlrpc.la
-libkabc_xmlrpc_la_SOURCES = kabc_resourcexmlrpc.cpp kabc_resourcexmlrpcconfig.cpp \
- kabc_egroupwareprefs.kcfgc
-libkabc_xmlrpc_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -version-info 1:0:0 -no-undefined
-libkabc_xmlrpc_la_LIBADD = $(LIB_KIO) -lkabc $(top_builddir)/libtdepim/libtdepim.la \
- $(top_builddir)/kaddressbook/common/libkabcommon.la \
- libegwcommon.la
-
-libkcal_xmlrpc_la_SOURCES = kcal_resourcexmlrpc.cpp kcal_resourcexmlrpcconfig.cpp \
- todostatemapper.cpp kcal_egroupwareprefs.kcfgc
-libkcal_xmlrpc_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -version-info 1:0:0 -no-undefined
-libkcal_xmlrpc_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
- $(top_builddir)/libtdepim/libtdepim.la \
- libegwcommon.la
-
-libknotes_xmlrpc_la_SOURCES = knotes_resourcexmlrpc.cpp knotes_resourcexmlrpcconfig.cpp \
- knotes_egroupwareprefs.kcfgc
-libknotes_xmlrpc_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -version-info 1:0:0 -no-undefined
-libknotes_xmlrpc_la_LIBADD = $(top_builddir)/libkcal/libkcal.la -ltdeprint \
- $(top_builddir)/knotes/libknotesresources.la \
- $(top_builddir)/libtdepim/libtdepim.la \
- libegwcommon.la
-
-kabcincludedir = $(includedir)/kabc
-kabcinclude_HEADERS = kabc_resourcexmlrpc.h kcal_resourcexmlrpc.h
-
-kde_module_LTLIBRARIES = kabc_xmlrpc.la kcal_xmlrpc.la knotes_xmlrpc.la
-
-kabc_xmlrpc_la_SOURCES = kabc_resourcexmlrpcplugin.cpp
-kabc_xmlrpc_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
-kabc_xmlrpc_la_LIBADD = libkabc_xmlrpc.la
-
-kcal_xmlrpc_la_SOURCES = kcal_resourcexmlrpcplugin.cpp
-kcal_xmlrpc_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
-kcal_xmlrpc_la_LIBADD = libkcal_xmlrpc.la
-
-knotes_xmlrpc_la_SOURCES = knotes_resourcexmlrpcplugin.cpp
-knotes_xmlrpc_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
-knotes_xmlrpc_la_LIBADD = libknotes_xmlrpc.la
-
-kabc_servicedir = $(kde_servicesdir)/kresources/kabc
-kabc_service_DATA = kabc_xmlrpc.desktop
-
-kcal_servicedir = $(kde_servicesdir)/kresources/kcal
-kcal_service_DATA = kcal_xmlrpc.desktop
-
-knotes_servicedir = $(kde_servicesdir)/kresources/knotes
-knotes_service_DATA = knotes_xmlrpc.desktop
-
-METASOURCES = AUTO
-
-messages: rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/kres_xmlrpc.pot
-
-kabc_resourcexmlrpc.lo: ../../kaddressbook/common/kabprefs_base.h