summaryrefslogtreecommitdiffstats
path: root/kresources/groupwise/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 00:29:04 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 00:29:04 +0000
commitf5b07a4a12d57d28dee8662d296dd400d26ba7fe (patch)
tree24b4c61a0576f1c5d3571cc8d6c81262e6171227 /kresources/groupwise/CMakeLists.txt
parent6bab61d816e8321b2d66a7183af04269a832ea81 (diff)
downloadtdepim-f5b07a4a12d57d28dee8662d296dd400d26ba7fe.tar.gz
tdepim-f5b07a4a12d57d28dee8662d296dd400d26ba7fe.zip
[kdepim] initial cmake support for: knotes, kode, korganizer, kresources, plugins, wizards
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1225440 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/groupwise/CMakeLists.txt')
-rw-r--r--kresources/groupwise/CMakeLists.txt75
1 files changed, 75 insertions, 0 deletions
diff --git a/kresources/groupwise/CMakeLists.txt b/kresources/groupwise/CMakeLists.txt
new file mode 100644
index 000000000..2b661be91
--- /dev/null
+++ b/kresources/groupwise/CMakeLists.txt
@@ -0,0 +1,75 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( soap )
+add_subdirectory( kioslave )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libkdepim
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kcal_groupwise.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kcal )
+install( FILES kabc_groupwise.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kabc )
+
+
+##### kcal_groupwise (module) ###################
+
+tde_add_kpart( kcal_groupwise AUTOMOC
+ SOURCES kcal_resourcegroupwise_plugin.cpp
+ LINK kcal_groupwise-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kabc_groupwise (module) ###################
+
+tde_add_kpart( kabc_groupwise AUTOMOC
+ SOURCES kabc_resourcegroupwise_plugin.cpp
+ LINK kabc_groupwise-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kcal_groupwise (shared) ###################
+
+tde_add_library( kcal_groupwise SHARED AUTOMOC
+ SOURCES
+ kcal_resourcegroupwise.cpp kcal_resourcegroupwiseconfig.cpp
+ kcal_groupwiseprefsbase.kcfgc kcal_groupwiseprefs.cpp
+ groupwisesettingswidget.cpp groupwisesettingswidgetbase.ui
+ VERSION 1.0.0
+ LINK gwsoap-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### kabc_groupwise (shared) ###################
+
+tde_add_library( kabc_groupwise SHARED AUTOMOC
+ SOURCES
+ kabc_resourcegroupwise.cpp kabc_resourcegroupwiseconfig.cpp
+ kabc_groupwiseprefs.kcfgc
+ VERSION 1.0.0
+ LINK gwsoap-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)