summaryrefslogtreecommitdiffstats
path: root/kresources/kolab/kabc/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /kresources/kolab/kabc/Makefile.am
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kresources/kolab/kabc/Makefile.am')
-rw-r--r--kresources/kolab/kabc/Makefile.am27
1 files changed, 0 insertions, 27 deletions
diff --git a/kresources/kolab/kabc/Makefile.am b/kresources/kolab/kabc/Makefile.am
deleted file mode 100644
index 2a906a45e..000000000
--- a/kresources/kolab/kabc/Makefile.am
+++ /dev/null
@@ -1,27 +0,0 @@
-METASOURCES = AUTO
-
-INCLUDES = -I$(top_srcdir)/kresources/kolab/shared -I$(top_srcdir) $(all_includes)
-
-# The kolab wizard links to this library too
-lib_LTLIBRARIES = libkabckolab.la
-
-libkabckolab_la_SOURCES = resourcekolab.cpp contact.cpp
-libkabckolab_la_LDFLAGS = $(all_libraries) -no-undefined
-libkabckolab_la_LIBADD = \
- $(top_builddir)/kresources/kolab/shared/libresourcekolabshared.la \
- -lkresources -lkabc
-
-kde_module_LTLIBRARIES = kabc_kolab.la
-
-noinst_HEADERS = resourcekolab.h contact.h
-
-kabc_kolab_la_SOURCES = resourcekolab_plugin.cpp
-kabc_kolab_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
-kabc_kolab_la_LIBADD = libkabckolab.la
-
-servicedir = $(kde_servicesdir)/kresources/kabc
-service_DATA = kolab.desktop
-
-install-data-local: $(srcdir)/../uninstall.desktop
- $(mkinstalldirs) $(DESTDIR)$(servicedir)
- $(INSTALL_DATA) $(srcdir)/../uninstall.desktop $(DESTDIR)$(servicedir)/imap.desktop