summaryrefslogtreecommitdiffstats
path: root/kresources/lib/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kresources/lib/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/lib/Makefile.am')
-rw-r--r--kresources/lib/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/kresources/lib/Makefile.am b/kresources/lib/Makefile.am
new file mode 100644
index 000000000..0b3f29b6e
--- /dev/null
+++ b/kresources/lib/Makefile.am
@@ -0,0 +1,39 @@
+INCLUDES = -I$(top_srcdir) \
+-I$(top_srcdir)/libkcal/libical/src/libical -I$(top_srcdir)/libkcal/libical/src/libicalss \
+ -I$(top_builddir)/libkcal/libical/src/libical -I$(top_builddir)/libkcal/libical/src/libicalss \
+ $(all_includes)
+
+lib_LTLIBRARIES = libkgroupwarebase.la libkgroupwaredav.la
+
+libkgroupwarebase_la_SOURCES = folderlister.cpp folderconfig.cpp folderlistview.cpp folderselectdialog.cpp \
+ groupwaredataadaptor.cpp groupwaredownloadjob.cpp \
+ calendaradaptor.cpp addressbookadaptor.cpp groupwareresourcejob.cpp \
+ groupwareuploadjob.cpp kcal_resourcegroupwarebase.cpp kabc_resourcegroupwarebase.cpp \
+ kresources_groupwareprefs.kcfgc \
+ kcal_resourcegroupwarebaseconfig.cpp kabc_resourcegroupwarebaseconfig.cpp \
+ kcal_cachesettingsdlg.cpp
+libkgroupwarebase_la_LDFLAGS = $(all_libraries) -no-undefined
+libkgroupwarebase_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkdepim/libkdepim.la
+
+libkgroupwaredav_la_SOURCES = davcalendaradaptor.cpp davaddressbookadaptor.cpp webdavhandler.cpp \
+ davgroupwareglobals.cpp
+libkgroupwaredav_la_LDFLAGS = $(all_libraries) -no-undefined
+libkgroupwaredav_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkdepim/libkdepim.la libkgroupwarebase.la
+
+METASOURCES = AUTO
+
+### We use three (or more) namespaces here in here - KPIM, KABC and KCal.
+### When using multiple "using namespace foo" declarations, namespaced
+### definitions cannot be resolved properly; we could use namespace foo { }
+### instead, but this breaks on KConfigXT generated code, which still uses
+### "using namespace" and can't be fixed due to our backwards-compatibility
+### requirements. This is only fatal when doing --enable-final, since only
+### then do all the namespaces get mixed together.
+KDE_OPTIONS = nofinal
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kdepimresources.pot
+
+webdavhandler.lo: ../../libkcal/libical/src/libical/ical.h