summaryrefslogtreecommitdiffstats
path: root/libkdenetwork/gpgmepp/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /libkdenetwork/gpgmepp/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'libkdenetwork/gpgmepp/Makefile.am')
-rw-r--r--libkdenetwork/gpgmepp/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/libkdenetwork/gpgmepp/Makefile.am b/libkdenetwork/gpgmepp/Makefile.am
new file mode 100644
index 000000000..01d72de3f
--- /dev/null
+++ b/libkdenetwork/gpgmepp/Makefile.am
@@ -0,0 +1,52 @@
+KDE_OPTIONS = foreign
+#AM_CXXFLAGS = -Wno-deprecated-declarations
+
+SUBDIRS = interfaces .
+
+INCLUDES = -I$(top_srcdir)/libkdenetwork -I$(top_srcdir)/libkdenetwork/gpgmepp \
+ $(GPGME_CFLAGS) $(all_includes)
+
+gpgmeppdir = $(includedir)/gpgme++
+gpgmepp_HEADERS = context.h \
+ key.h \
+ trustitem.h \
+ eventloopinteractor.h \
+ data.h \
+ gpgmefw.h \
+ result.h \
+ keylistresult.h \
+ keygenerationresult.h \
+ importresult.h \
+ decryptionresult.h \
+ verificationresult.h \
+ signingresult.h \
+ encryptionresult.h \
+ engineinfo.h
+
+noinst_HEADERS = context_p.h data_p.h shared.h callbacks.h gpgme-0-3-compat.h result_p.h util.h
+
+lib_LTLIBRARIES = libgpgme++.la
+libgpgme___la_SOURCES = context.cpp \
+ key.cpp \
+ trustitem.cpp \
+ data.cpp \
+ callbacks.cpp \
+ eventloopinteractor.cpp \
+ keylistresult.cpp \
+ keygenerationresult.cpp \
+ importresult.cpp \
+ decryptionresult.cpp \
+ verificationresult.cpp \
+ signingresult.cpp \
+ encryptionresult.cpp \
+ engineinfo.cpp
+
+# --version-info CURRENT:REVISION:AGE
+# (Code changed: REVISION++)
+# (Interfaces added/removed/changed: CURRENT++, REVISION=0)
+# (Interfaces added: AGE++)
+# (Interfaces removed/changed: AGE=0)
+libgpgme___la_LDFLAGS = -no-undefined -version-info 4:0:4
+libgpgme___la_LIBADD = $(GPGME_LIBS)
+libgpgme___la_DEPENDENCIES = $(GPGME_LIBS_DEP)
+