summaryrefslogtreecommitdiffstats
path: root/libkdepim/komposer/core/tests/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-10 20:45:10 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-10 20:45:10 +0000
commit0451bfa1dfdda10f7a0dc04277066f10648d37f8 (patch)
treee372421b17ffb8ec9944e753c504a84873cf604c /libkdepim/komposer/core/tests/Makefile.am
parentbd4d40e62f0ade42fbc594c1c87dfc93dfab8c99 (diff)
downloadtdepim-0451bfa1dfdda10f7a0dc04277066f10648d37f8.tar.gz
tdepim-0451bfa1dfdda10f7a0dc04277066f10648d37f8.zip
Link most Trinity DSOs against the most common kdelibs libraries to compensate for linking changes in modern distributions such as Ubuntu Oneiricv3.5.13
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1258263 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'libkdepim/komposer/core/tests/Makefile.am')
-rw-r--r--libkdepim/komposer/core/tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libkdepim/komposer/core/tests/Makefile.am b/libkdepim/komposer/core/tests/Makefile.am
index de3a40f90..187387f35 100644
--- a/libkdepim/komposer/core/tests/Makefile.am
+++ b/libkdepim/komposer/core/tests/Makefile.am
@@ -5,15 +5,15 @@ check_PROGRAMS = testfactory testmanager testkomposer
METASOURCES = AUTO
testfactory_SOURCES = main.cpp managertest.cpp
-testfactory_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testfactory_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
testfactory_LDADD = ../libkomposer.la
testmanager_SOURCES = testmanager.cpp
-testmanager_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testmanager_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
testmanager_LDADD = ../libkomposer.la
testkomposer_SOURCES = testkomposer.cpp
-testkomposer_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testkomposer_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
testkomposer_LDADD = ../libkomposer.la
check: testfactory