summaryrefslogtreecommitdiffstats
path: root/mimelib/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /mimelib/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'mimelib/Makefile.am')
-rw-r--r--mimelib/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/mimelib/Makefile.am b/mimelib/Makefile.am
new file mode 100644
index 000000000..f977a6815
--- /dev/null
+++ b/mimelib/Makefile.am
@@ -0,0 +1,67 @@
+# UNIX makefile for MIME++ library and example programs
+
+# Choose a version to compile. I recommend compiling development version,
+# which includes numerous assert macros to catch bad function arguments
+# and other safeguards. The production version is designed to avoid
+# program aborts, such as will occur if an assertion fails. The production
+# version tries to recover as best it can in the case of exceptional
+# conditions. The debug version is designed to help you find bugs once
+# you know they exist. The development version helps you out here just
+# a little, because it will dump core so you can examine the program
+# state with a debugger.
+#
+# Make sure you type 'make clean' after compiling one version before
+# compiling a different version.
+
+SUBDIRS = mimelib
+
+LIBVERSION = DW_DEVELOPMENT_VERSION
+# LIBVERSION = DW_PRODUCTION_VERSION
+# LIBVERSION = DW_DEBUG_VERSION
+
+INCLUDES = $(all_includes)
+
+AM_CPPFLAGS = -D$(LIBVERSION) -D_REENTRANT
+lib_LTLIBRARIES = libmimelib.la
+
+libmimelib_la_SOURCES = \
+ protocol.cpp \
+ address.cpp \
+ addrlist.cpp \
+ body.cpp \
+ bodypart.cpp \
+ boyermor.cpp \
+ datetime.cpp \
+ disptype.cpp \
+ dw_cte.cpp \
+ dw_date.cpp \
+ dw_mime.cpp \
+ entity.cpp \
+ field.cpp \
+ fieldbdy.cpp \
+ group.cpp \
+ headers.cpp \
+ mailbox.cpp \
+ mboxlist.cpp \
+ mechansm.cpp \
+ mediatyp.cpp \
+ message.cpp \
+ msgcmp.cpp \
+ msgid.cpp \
+ nntp.cpp \
+ param.cpp \
+ pop.cpp \
+ dwstring.cpp \
+ text.cpp \
+ token.cpp \
+ uuencode.cpp \
+ binhex.cpp
+
+libmimelib_la_LDFLAGS = -L$(kde_libraries) -lkdefakes -version-info 1:1 -no-undefined
+
+check_PROGRAMS = test_boyermor
+
+TESTS=$(check_PROGRAMS)
+
+test_boyermor_SOURCES = test_boyermor.cpp
+test_boyermor_LDADD = libmimelib.la $(LIBSOCKET)