summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/palm-databases/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /tdefile-plugins/palm-databases/Makefile.am
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/palm-databases/Makefile.am')
-rw-r--r--tdefile-plugins/palm-databases/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/palm-databases/Makefile.am b/tdefile-plugins/palm-databases/Makefile.am
new file mode 100644
index 000000000..552a2a4fe
--- /dev/null
+++ b/tdefile-plugins/palm-databases/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for palm database meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(PISOCK_INCLUDE) $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_palm.h
+
+kde_module_LTLIBRARIES = tdefile_palm.la
+
+tdefile_palm_la_SOURCES = tdefile_palm.cpp
+tdefile_palm_la_LDFLAGS = $(PISOCK_LDFLAGS) $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -ltdecore
+tdefile_palm_la_LIBADD = $(LIB_KSYCOCA) $(PISOCK_LIB)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) tdefile_palm.cpp -o $(podir)/tdefile_palm.pot
+
+services_DATA = tdefile_palm.desktop
+servicesdir = $(kde_servicesdir)