summaryrefslogtreecommitdiffstats
path: root/tdeioslave/mbox/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2014-02-06 17:54:49 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2014-02-06 17:54:49 -0600
commitca705978d11b2e0bdcaf8186b0addff48d851483 (patch)
treeda2d37c0fc29b1746cc24594e948bc7c9f1241eb /tdeioslave/mbox/Makefile.am
parenteaa1b143397fadcb31d69944ed69d6cf215be77d (diff)
downloadtdepim-ca705978d11b2e0bdcaf8186b0addff48d851483.tar.gz
tdepim-ca705978d11b2e0bdcaf8186b0addff48d851483.zip
Reorganize tdeioslave help handbooks, fix related protocol files and issues, update and add handbooks.
Diffstat (limited to 'tdeioslave/mbox/Makefile.am')
-rw-r--r--tdeioslave/mbox/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/tdeioslave/mbox/Makefile.am b/tdeioslave/mbox/Makefile.am
new file mode 100644
index 000000000..4dea4644a
--- /dev/null
+++ b/tdeioslave/mbox/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES= $(all_includes)
+
+####### Files
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = tdeio_mbox.la
+
+tdeio_mbox_la_SOURCES = \
+ mbox.cc \
+ mboxfile.cc \
+ readmbox.cc \
+ stat.cc \
+ urlinfo.cc
+tdeio_mbox_la_LIBADD = $(LIB_TDEIO) $(LIB_QT) $(LIB_TDECORE)
+tdeio_mbox_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -module $(KDE_PLUGIN)
+
+noinst_HEADERS = \
+ mbox.h \
+ mboxfile.h \
+ readmbox.h \
+ stat.h \
+ urlinfo.h
+
+kdelnk_DATA = mbox.protocol
+kdelnkdir = $(kde_servicesdir)
+
+
+include $(top_srcdir)/admin/Doxyfile.am
+