summaryrefslogtreecommitdiffstats
path: root/tderesources/exchange/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /tderesources/exchange/Makefile.am
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tderesources/exchange/Makefile.am')
-rw-r--r--tderesources/exchange/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tderesources/exchange/Makefile.am b/tderesources/exchange/Makefile.am
new file mode 100644
index 000000000..a9fdf70a6
--- /dev/null
+++ b/tderesources/exchange/Makefile.am
@@ -0,0 +1,23 @@
+METASOURCES = AUTO
+
+INCLUDES = -I$(top_srcdir)/korganizer/interfaces \
+ -I$(top_srcdir)/interfaces \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libkpimexchange/core -I$(top_builddir)/libkpimexchange/core \
+ -I$(top_srcdir)/libical/src/libical -I$(top_srcdir)/libical/src/libicalss \
+ -I$(top_builddir)/libical/src/libical -I$(top_builddir)/libical/src/libicalss \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = resourcecalendarexchange.la
+
+resourcecalendarexchange_la_SOURCES = resourceexchange.cpp resourceexchangeconfig.cpp dateset.cpp
+resourcecalendarexchange_la_LDFLAGS= $(all_libraries) -module $(KDE_PLUGIN)
+resourcecalendarexchange_la_LIBADD= -ltderesources \
+ $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkpimexchange/libkpimexchange.la
+
+servicedir = $(kde_servicesdir)/tderesources/kcal
+service_DATA= exchange.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kres_exchange.pot