summaryrefslogtreecommitdiffstats
path: root/tderesources/kolab/shared/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /tderesources/kolab/shared/Makefile.am
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tderesources/kolab/shared/Makefile.am')
-rw-r--r--tderesources/kolab/shared/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tderesources/kolab/shared/Makefile.am b/tderesources/kolab/shared/Makefile.am
new file mode 100644
index 000000000..287620330
--- /dev/null
+++ b/tderesources/kolab/shared/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/tderesources/lib $(all_includes)
+
+noinst_HEADERS = resourcekolabbase.h kolabbase.h subresource.h
+
+noinst_LTLIBRARIES = libresourcekolabshared.la
+
+libresourcekolabshared_la_SOURCES = \
+ resourcekolabbase.cpp kmailconnection.cpp kolabbase.cpp \
+ subresource.cpp \
+ kmailconnection.skel kmailicalIface.stub
+libresourcekolabshared_la_METASOURCES = AUTO
+libresourcekolabshared_la_LIBADD = $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libtdepim/libtdepim.la ../../lib/libkgroupwarebase.la
+libresourcekolabshared_la_LDFLAGS = -no-undefined
+
+kmailicalIface_DCOPIDLNG = true
+
+kmailicalIface_DIR = $(top_srcdir)/kmail