summaryrefslogtreecommitdiffstats
path: root/tderesources/scalix/scalixadmin/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /tderesources/scalix/scalixadmin/CMakeLists.txt
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tderesources/scalix/scalixadmin/CMakeLists.txt')
-rw-r--r--tderesources/scalix/scalixadmin/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/tderesources/scalix/scalixadmin/CMakeLists.txt b/tderesources/scalix/scalixadmin/CMakeLists.txt
new file mode 100644
index 000000000..f13d11a83
--- /dev/null
+++ b/tderesources/scalix/scalixadmin/CMakeLists.txt
@@ -0,0 +1,33 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### scalixadmin (executable) ##################
+
+tde_add_executable( scalixadmin AUTOMOC
+ SOURCES
+ main.cpp mainwindow.cpp passwordpage.cpp settings.cpp jobs.cpp
+ otherusermanager.cpp otheruserview.cpp otheruserpage.cpp ldapview.cpp
+ ldapdialog.cpp delegatemanager.cpp delegateview.cpp delegatepage.cpp
+ delegatedialog.cpp outofofficepage.cpp
+ LINK kabc-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)