summaryrefslogtreecommitdiffstats
path: root/tderesources/scalix/tdeabc/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-17 23:41:27 +0000
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-17 23:41:27 +0000
commit070482fcc398b8c5c25c8d3add69ed975ea2edd4 (patch)
tree0f100dc5bc86b0f5877cb74a02669ecf16122a4a /tderesources/scalix/tdeabc/Makefile.am
parent00260fbb76eae21106094be8736ef0f1dabde387 (diff)
downloadtdepim-070482fcc398b8c5c25c8d3add69ed975ea2edd4.tar.gz
tdepim-070482fcc398b8c5c25c8d3add69ed975ea2edd4.zip
Fix FTBFS
Diffstat (limited to 'tderesources/scalix/tdeabc/Makefile.am')
-rw-r--r--tderesources/scalix/tdeabc/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/tderesources/scalix/tdeabc/Makefile.am b/tderesources/scalix/tdeabc/Makefile.am
new file mode 100644
index 000000000..e8bbc3bbc
--- /dev/null
+++ b/tderesources/scalix/tdeabc/Makefile.am
@@ -0,0 +1,27 @@
+METASOURCES = AUTO
+
+INCLUDES = -I$(top_srcdir)/tderesources/scalix/shared -I$(top_srcdir) $(all_includes)
+
+# The scalix wizard links to this library too
+lib_LTLIBRARIES = libkabcscalix.la
+
+libkabcscalix_la_SOURCES = resourcescalix.cpp contact.cpp
+libkabcscalix_la_LDFLAGS = $(all_libraries) -no-undefined
+libkabcscalix_la_LIBADD = \
+ $(top_builddir)/tderesources/scalix/shared/libresourcescalixshared.la \
+ -ltderesources -lkabc
+
+kde_module_LTLIBRARIES = tdeabc_scalix.la
+
+noinst_HEADERS = resourcescalix.h
+
+tdeabc_scalix_la_SOURCES = resourcescalix_plugin.cpp
+tdeabc_scalix_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+tdeabc_scalix_la_LIBADD = libkabcscalix.la
+
+servicedir = $(kde_servicesdir)/tderesources/tdeabc
+service_DATA = scalix.desktop
+
+install-data-local: $(srcdir)/../uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(servicedir)
+ $(INSTALL_DATA) $(srcdir)/../uninstall.desktop $(DESTDIR)$(servicedir)/imap.desktop