summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/knode/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/knode/Makefile.am')
-rw-r--r--kontact/plugins/knode/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/kontact/plugins/knode/Makefile.am b/kontact/plugins/knode/Makefile.am
new file mode 100644
index 000000000..bf4ba753a
--- /dev/null
+++ b/kontact/plugins/knode/Makefile.am
@@ -0,0 +1,14 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir)/knode -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_knodeplugin.la
+libkontact_knodeplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_knodeplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la $(LIB_KPARTS)
+
+libkontact_knodeplugin_la_SOURCES = knode_plugin.cpp knodeiface.stub
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = knodeplugin.desktop
+
+knodeiface_DIR = $(top_srcdir)/knode