summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/test/Makefile.am')
-rw-r--r--kontact/plugins/test/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kontact/plugins/test/Makefile.am b/kontact/plugins/test/Makefile.am
new file mode 100644
index 000000000..3fbac9eb3
--- /dev/null
+++ b/kontact/plugins/test/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces $(all_includes)
+
+kde_module_LTLIBRARIES = libkptestplugin.la
+libkptestplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkptestplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la $(LIB_KPARTS)
+
+libkptestplugin_la_SOURCES = test_plugin.cpp test_part.cpp kaddressbookiface.stub
+
+kaddressbookiface_DIR = $(top_srcdir)/kaddressbook
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kptestplugin.desktop
+
+rc_DATA = kptestplugin.rc
+rcdir = $(kde_datadir)/kptestplugin
+
+kpartrc_DATA = testpartui.rc
+kpartrcdir = $(kde_datadir)/testpart