summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/weather/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/weather/Makefile.am')
-rw-r--r--kontact/plugins/weather/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/kontact/plugins/weather/Makefile.am b/kontact/plugins/weather/Makefile.am
new file mode 100644
index 000000000..dc547a0ce
--- /dev/null
+++ b/kontact/plugins/weather/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir)/libkdepim -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_weatherplugin.la
+libkontact_weatherplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_weatherplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la $(LIB_KPARTS) $(top_builddir)/libkdepim/libkdepim.la
+
+libkontact_weatherplugin_la_SOURCES = weather_plugin.cpp summarywidget.cpp \
+ summarywidget.skel
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = weatherplugin.desktop