summaryrefslogtreecommitdiffstats
path: root/libkdenetwork/gpgmepp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libkdenetwork/gpgmepp/CMakeLists.txt')
-rw-r--r--libkdenetwork/gpgmepp/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/libkdenetwork/gpgmepp/CMakeLists.txt b/libkdenetwork/gpgmepp/CMakeLists.txt
deleted file mode 100644
index cf4efc7f7..000000000
--- a/libkdenetwork/gpgmepp/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-add_subdirectory( interfaces )
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}/libtdenetwork
- ${CMAKE_SOURCE_DIR}/libtdepim
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
- ${GPGME_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### headers ###################################
-
-install( FILES
- context.h key.h trustitem.h eventloopinteractor.h
- data.h gpgmefw.h result.h keylistresult.h
- keygenerationresult.h importresult.h decryptionresult.h
- verificationresult.h signingresult.h encryptionresult.h
- engineinfo.h
- DESTINATION ${INCLUDE_INSTALL_DIR}/kde/gpgme++ )
-
-
-##### gpgme++ (shared) ##########################
-
-tde_add_library( gpgme++ SHARED
- SOURCES
- context.cpp key.cpp trustitem.cpp data.cpp
- callbacks.cpp eventloopinteractor.cpp
- keylistresult.cpp keygenerationresult.cpp
- importresult.cpp decryptionresult.cpp
- verificationresult.cpp signingresult.cpp
- encryptionresult.cpp engineinfo.cpp
- VERSION 0.4.0
- LINK ${TQT_LIBRARIES} ${GPGME_LIBRARIES}
- DESTINATION ${LIB_INSTALL_DIR}
-)