summaryrefslogtreecommitdiffstats
path: root/libkpgp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libkpgp/Makefile.am')
-rw-r--r--libkpgp/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/libkpgp/Makefile.am b/libkpgp/Makefile.am
new file mode 100644
index 000000000..3b99ef8b4
--- /dev/null
+++ b/libkpgp/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES = $(all_includes)
+SUBDIRS = pics
+
+lib_LTLIBRARIES = libkpgp.la
+
+libkpgp_la_SOURCES = \
+ kpgpblock.cpp \
+ kpgpui.cpp \
+ kpgpkey.cpp \
+ kpgp.cpp \
+ kpgpbase.cpp \
+ kpgpbaseG.cpp \
+ kpgpbase2.cpp \
+ kpgpbase5.cpp \
+ kpgpbase6.cpp
+
+libkpgp_la_LDFLAGS = $(all_libraries) -no-undefined -version-info 4:0:2
+
+libkpgp_la_LIBADD = $(LIB_KDEUI) $(LIB_POLL)
+
+METASOURCES = AUTO
+
+updatedir = $(kde_datadir)/kconf_update
+update_DATA = kpgp.upd
+update_SCRIPTS = kpgp-3.1-upgrade-address-data.pl
+
+messages:
+ $(XGETTEXT) *.cpp *.h -o $(podir)/libkpgp.pot
+
+include $(top_srcdir)/admin/Doxyfile.am