summaryrefslogtreecommitdiffstats
path: root/kbugbuster/backend/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-18 18:38:56 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-19 10:19:10 +0200
commita6048b8b5d1195f0736469c0670456ed9f24570c (patch)
tree65ebcf8198ad4443d6c3b5aebf95a8a29bf32668 /kbugbuster/backend/CMakeLists.txt
parent0ed1f8dbedca3eff92941e2a1181b90425560f68 (diff)
downloadtdesdk-a6048b8b5d1195f0736469c0670456ed9f24570c.tar.gz
tdesdk-a6048b8b5d1195f0736469c0670456ed9f24570c.zip
kbugbuster: Build only the PIC variant of the static backend library.
This should resolve the occasional FTBFS caused by double generation of the same MOC files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit f49ad59af0fb02cb29968960cb6a380649dc07c6)
Diffstat (limited to 'kbugbuster/backend/CMakeLists.txt')
-rw-r--r--kbugbuster/backend/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/kbugbuster/backend/CMakeLists.txt b/kbugbuster/backend/CMakeLists.txt
index 64b8ca6b..cb3b83c2 100644
--- a/kbugbuster/backend/CMakeLists.txt
+++ b/kbugbuster/backend/CMakeLists.txt
@@ -26,12 +26,6 @@ set( SRCS
rdfprocessor.cpp htmlparser.cpp kbbprefs.cpp
)
-tde_add_library( kbbbackend_nopic STATIC AUTOMOC
+tde_add_library( kbbbackend STATIC_PIC AUTOMOC
SOURCES ${SRCS}
)
-
-if( WITH_KCAL )
- tde_add_library( kbbbackend_pic STATIC_PIC AUTOMOC
- SOURCES ${SRCS}
- )
-endif( )