summaryrefslogtreecommitdiffstats
path: root/kbugbuster/tderesources/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:59 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:59 -0600
commit1515a4f2eb9cf023ed7f9c2e10106b5e93164a08 (patch)
treed5617734090b254659ff331ce7d1e574c4807caf /kbugbuster/tderesources/CMakeLists.txt
parentf8069e2ea048f2657cc417d83820576ec55c181b (diff)
downloadtdesdk-1515a4f2eb9cf023ed7f9c2e10106b5e93164a08.tar.gz
tdesdk-1515a4f2eb9cf023ed7f9c2e10106b5e93164a08.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kbugbuster/tderesources/CMakeLists.txt')
-rw-r--r--kbugbuster/tderesources/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/kbugbuster/tderesources/CMakeLists.txt b/kbugbuster/tderesources/CMakeLists.txt
new file mode 100644
index 00000000..ec5956a3
--- /dev/null
+++ b/kbugbuster/tderesources/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../backend
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${LIBKCAL_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${LIBKCAL_LIBRARY_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES
+ bugzilla.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/kcal )
+
+
+##### kcal_bugzilla (module) ####################
+
+tde_add_kpart( kcal_bugzilla AUTOMOC
+ SOURCES
+ kcalresource.cpp kcalresourceconfig.cpp
+ kcalresource_plugin.cpp resourceprefs.kcfgc
+ LINK kbbbackend_pic-static tdecore-shared kio-shared kabc kcal tderesources
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)