summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/c++/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbd9e6617827818fd043452c08c606f07b78014a0 (patch)
tree425bb4c3168f9c02f10150f235d2cb998dcc6108 /kfile-plugins/c++/Makefile.am
downloadtdesdk-bd9e6617827818fd043452c08c606f07b78014a0.tar.gz
tdesdk-bd9e6617827818fd043452c08c606f07b78014a0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdesdk@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/c++/Makefile.am')
-rw-r--r--kfile-plugins/c++/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kfile-plugins/c++/Makefile.am b/kfile-plugins/c++/Makefile.am
new file mode 100644
index 00000000..4770b509
--- /dev/null
+++ b/kfile-plugins/c++/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for c++ file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_cpp.h
+
+kde_module_LTLIBRARIES = kfile_cpp.la
+
+kfile_cpp_la_SOURCES = kfile_cpp.cpp
+kfile_cpp_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_cpp_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kfile_cpp.pot
+
+services_DATA = kfile_cpp.desktop kfile_h.desktop
+servicesdir = $(kde_servicesdir)