summaryrefslogtreecommitdiffstats
path: root/tdeioslave/svn/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:39 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:39 -0600
commitff94d46e423398804d2ae63faeb114c2cf604fc4 (patch)
tree4481ffd491d15ac15081cea46d7cc298ef6351a4 /tdeioslave/svn/Makefile.am
parentb9553cef2a3cd9f5b89c8aca6f4b7781a079dbb7 (diff)
downloadtdesdk-ff94d46e423398804d2ae63faeb114c2cf604fc4.tar.gz
tdesdk-ff94d46e423398804d2ae63faeb114c2cf604fc4.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/svn/Makefile.am')
-rw-r--r--tdeioslave/svn/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tdeioslave/svn/Makefile.am b/tdeioslave/svn/Makefile.am
new file mode 100644
index 00000000..35efdfc7
--- /dev/null
+++ b/tdeioslave/svn/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = ksvnd svnhelper icons
+
+INCLUDES = $(SVN_INCLUDE) $(all_includes)
+
+kde_module_LTLIBRARIES = kio_svn.la
+
+kio_svn_la_SOURCES = svn.cpp
+kio_svn_la_LIBADD = -lkio
+kio_svn_la_LDFLAGS = -avoid-version -module $(all_libraries) $(KDE_PLUGIN) $(SVNLD) $(SVN_LIB)
+
+protocol_DATA = svn+http.protocol svn+https.protocol svn+file.protocol svn+ssh.protocol svn.protocol
+protocoldir = $(kde_servicesdir)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_svn.pot