summaryrefslogtreecommitdiffstats
path: root/cervisia/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cervisia/CMakeLists.txt')
-rw-r--r--cervisia/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/cervisia/CMakeLists.txt b/cervisia/CMakeLists.txt
index 620cb602..b4f6f7c3 100644
--- a/cervisia/CMakeLists.txt
+++ b/cervisia/CMakeLists.txt
@@ -58,6 +58,24 @@ install( PROGRAMS
DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+macro( _pod2man )
+ foreach( _pod ${ARGN} )
+ add_custom_command(
+ OUTPUT ${_pod}.1
+ COMMAND pod2man ${CMAKE_CURRENT_SOURCE_DIR}/${_pod}.pod > ${_pod}.1.in
+ COMMAND
+ sed -e 's%_KDEHTMLDIR_%'${HTML_INSTALL_DIR}'%g;'
+ -e 's%_KDECONFDIR_%'${CONFIG_INSTALL_DIR}'%g;'
+ < ${_pod}.1.in > ${_pod}.1
+ DEPENDS ${_pod}.pod )
+ add_custom_target( "${_pod}-man" ALL DEPENDS ${_pod}.1 )
+ install( FILES ${CMAKE_CURRENT_BINARY_DIR}/${_pod}.1 DESTINATION ${MAN_INSTALL_DIR}/man1 )
+ endforeach( )
+endmacro()
+
+_pod2man( cervisia )
+
+
##### cervisia (static) #########################
tde_add_library( cervisia STATIC_PIC AUTOMOC