summaryrefslogtreecommitdiffstats
path: root/kbabel/kbabeldict/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kbabel/kbabeldict/Makefile.am')
-rw-r--r--kbabel/kbabeldict/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/kbabel/kbabeldict/Makefile.am b/kbabel/kbabeldict/Makefile.am
index e6ae7582..6eb129bb 100644
--- a/kbabel/kbabeldict/Makefile.am
+++ b/kbabel/kbabeldict/Makefile.am
@@ -19,19 +19,19 @@ INCLUDES = -I$(srcdir)/../common -I$(top_builddir)/kbabel/common $(all_i
lib_LTLIBRARIES = libkbabeldictplugin.la
libkbabeldictplugin_la_SOURCES = searchengine.cpp
libkbabeldictplugin_la_LIBADD = $(LIB_KDECORE)
-libkbabeldictplugin_la_LDFLAGS = -version-info 3:0:2 $(all_libraries)
+libkbabeldictplugin_la_LDFLAGS = -version-info 3:0:2 $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
libkbabeldict_la_SOURCES = kbabeldictbox.cpp \
kbabeldictiface.skel dictionarymenu.cpp dictchooser.cpp \
aboutmoduledlg.cpp
libkbabeldict_la_LIBADD = ../common/libkbabelcommon.la libkbabeldictplugin.la $(LIB_KDEUI)
-libkbabeldict_la_LDFLAGS = $(all_libraries) -no-undefined
+libkbabeldict_la_LDFLAGS = $(all_libraries) -no-undefined $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
kbabeldict_SOURCES = main.cpp kbabeldictview.cpp kbabeldict.cpp kbabelsplash.cpp
# the libraries to link against.
-kbabeldict_LDADD = libkbabeldict.la
+kbabeldict_LDADD = libkbabeldict.la $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
kbabeldict_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
# these are the headers for your project