summaryrefslogtreecommitdiffstats
path: root/tdeunittest/example/simple/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeunittest/example/simple/Makefile.am')
-rw-r--r--tdeunittest/example/simple/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdeunittest/example/simple/Makefile.am b/tdeunittest/example/simple/Makefile.am
new file mode 100644
index 00000000..0ee63452
--- /dev/null
+++ b/tdeunittest/example/simple/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = -I$(top_srcdir) $(all_includes)
+METASOURCES = AUTO
+
+check_PROGRAMS = sampletests sampletestsgui
+
+sampletests_SOURCES = main.cpp sampletest.cpp
+sampletests_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+sampletests_LDADD = -ltdeunittest
+
+sampletestsgui_SOURCES = maingui.cpp sampletest.cpp
+sampletestsgui_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+# Normally you would write -ltdeunittestgui here, but since the examples
+# are bundled with the library source code itself we don't want to
+# have you install the libraries before you can compile the examples.
+sampletestsgui_LDADD = ../../libtdeunittestgui.la
+
+noinst_HEADERS = sampletest.h
+
+TESTS = sampletests
+
+guicheck: sampletestsgui
+ tdeunittest ./sampletestsgui SampleTests