summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:09:50 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 21:30:24 +0900
commitd62bdc3dc1e887a565f05eb3186448e7bb4fb1c1 (patch)
tree36aae598ecc471bc568d54de1ab5c4faf5e47748 /CMakeLists.txt
parentbf98ebd6d55e26fcd4fbe70ff5e478a42545de32 (diff)
downloadtdesshaskpass-d62bdc3dc1e887a565f05eb3186448e7bb4fb1c1.tar.gz
tdesshaskpass-d62bdc3dc1e887a565f05eb3186448e7bb4fb1c1.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 2f3cdb918d13528442a57733ef9cd923ea2d8952)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6635735..c0e6a76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,12 @@
# #
############################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -31,11 +36,6 @@ include( FindPkgConfig )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )