summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt77
1 files changed, 66 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 481ab0a..be733cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,17 +1,72 @@
-project(ksshaskpass) # the name of your project
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
-cmake_minimum_required(VERSION 2.4.0)
+cmake_minimum_required( VERSION 2.8.12 )
-find_package(TQt REQUIRED) # find and setup TQt for this project
-find_package(KDE3 REQUIRED) # find and setup KDE3 for this project
-add_definitions(${QT_DEFINITIONS} ${KDE3_DEFINITIONS})
+##### general package setup #####################
-# tell cmake where to search for libraries:
-link_directories(${KDE3_LIB_DIR})
+project( ksshaskpass )
+set( VERSION 3.5.13.3 )
-# tell cmake where to search for Qt/KDE headers:
-include_directories(${KDE3_INCLUDE_DIR} ${QT_INCLUDE_DIR})
-# tell cmake to process CMakeLists.txt in that subdirectory
-add_subdirectory(src)
+##### include essential cmake modules ###########
+
+include( CheckCXXSourceCompiles )
+include( CheckFunctionExists )
+include( CheckIncludeFileCXX )
+include( CheckLibraryExists )
+include( CheckStructHasMember )
+include( CheckSymbolExists )
+include( CheckTypeSize )
+include( FindPkgConfig )
+
+
+##### include our cmake modules #################
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths #######################
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings #################
+
+add_definitions( -DHAVE_CONFIG_H )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+
+
+##### source directories ########################
+
+add_subdirectory( src )
+#tde_conditional_add_project_doc( BUILD_DOC )
+#tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
+##### write configure files #####################
+
+configure_file( config.h.cmake config.h @ONLY )