summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efda0f9..01037a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,6 +62,16 @@ IF(BUILD_TESTS)
ENDIF(BUILD_TESTS)
+##### versioning ################################
+
+SET(BASE_VERSION 1.0.4)
+SET(VERSION "$ENV{KDESVN_VERSION}")
+IF(NOT VERSION)
+ SET(VERSION ${BASE_VERSION})
+ENDIF(NOT VERSION)
+SET(KDESVN_VERSION \"${VERSION}\")
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -93,4 +103,4 @@ configure_file( tdesvn.spec.in tdesvn.spec @ONLY )
configure_file( Helperstuff/BuildService/tdesvn.spec.in Helperstuff/BuildService/tdesvn.spec @ONLY )
configure_file( Helperstuff/BuildService/tdesvn.dsc.in Helperstuff/BuildService/tdesvn.dsc @ONLY )
configure_file( Doxyfile.in Doxyfile @ONLY )
-configure_file( Doxyfile.svnqt.in Doxyfile.svnqt @ONLY ) \ No newline at end of file
+configure_file( Doxyfile.svnqt.in Doxyfile.svnqt @ONLY )