summaryrefslogtreecommitdiffstats
path: root/amor/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-18 15:33:48 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-18 15:33:48 +0100
commitc4c9c9fd262dd8450c1cf4454183b03173a3b092 (patch)
treee03d0b806ab851d79324ac05bc6fe06cdfe1fc0d /amor/CMakeLists.txt
parent75bf0c9d253aee7281a0d0d7e9f899d75a1bd04b (diff)
downloadtdetoys-c4c9c9fd262dd8450c1cf4454183b03173a3b092.tar.gz
tdetoys-c4c9c9fd262dd8450c1cf4454183b03173a3b092.zip
Initial conversion to cmake
Thanks to Fat-Zer
Diffstat (limited to 'amor/CMakeLists.txt')
-rw-r--r--amor/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/amor/CMakeLists.txt b/amor/CMakeLists.txt
new file mode 100644
index 0000000..750b0b9
--- /dev/null
+++ b/amor/CMakeLists.txt
@@ -0,0 +1,56 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( data )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### amor (executable) #########################
+
+tde_add_executable( amor AUTOMOC
+ SOURCES amordialog.cpp amor.cpp amorwidget.cpp
+ main.cpp amoranim.cpp amorpm.cpp
+ amorbubble.cpp amorconfig.cpp amortips.cpp
+ AmorIface.skel
+ LINK kio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### includes ##################################
+
+install( FILES AmorIface.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( amor )
+
+
+##### other data ################################
+
+install( FILES amor.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+