summaryrefslogtreecommitdiffstats
path: root/amor/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitae2a03c2941bf92573f89b88ef73f8aa842bea0a (patch)
tree3566563f3fb6ac3cb3496669d8f233062d3091bc /amor/Makefile.am
downloadtdetoys-ae2a03c2941bf92573f89b88ef73f8aa842bea0a.tar.gz
tdetoys-ae2a03c2941bf92573f89b88ef73f8aa842bea0a.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdetoys@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'amor/Makefile.am')
-rw-r--r--amor/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/amor/Makefile.am b/amor/Makefile.am
new file mode 100644
index 0000000..413c24e
--- /dev/null
+++ b/amor/Makefile.am
@@ -0,0 +1,38 @@
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+# claim, which subdirectories you want to install
+SUBDIRS = data
+
+####### This part is very amor specific
+# you can add here more. This one gets installed
+bin_PROGRAMS = amor
+
+# Which sources should be compiled for amor.
+amor_SOURCES = amordialog.cpp amor.cpp amorwidget.cpp main.cpp amoranim.cpp amorpm.cpp\
+ amorbubble.cpp amorconfig.cpp amortips.cpp AmorIface.skel
+
+include_HEADERS = AmorIface.h
+
+# the library search path
+amor_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+# the libraries to link against. Be aware of the order. First the libraries,
+# that depend on the following ones.
+amor_LDADD = $(LIB_KDEUI)
+
+# this option you can leave out. Just, if you use "make dist", you need it
+noinst_HEADERS = amor.h amorwidget.h amoranim.h amorpm.h amordialog.h\
+ amorbubble.h amorconfig.h amortips.h
+
+METASOURCES = AUTO
+
+messages:
+ perl ./preparetips > tips.cpp
+ $(XGETTEXT) tips.cpp *.cpp -o $(podir)/amor.pot
+ rm -f tips.cpp
+
+xdg_apps_DATA = amor.desktop
+
+KDE_ICON = amor
+