summaryrefslogtreecommitdiffstats
path: root/kteatime/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-15 11:55:19 +0200
commitd230ffe91600f31235f382cf8c0c5738a91101f9 (patch)
tree6b9198dabe0b78fe5e8ad6ed93232755310f5715 /kteatime/CMakeLists.txt
parentdcb03072211998dd141e3ade67c3d7bf7d8aa8f5 (diff)
downloadtdetoys-d230ffe91600f31235f382cf8c0c5738a91101f9.tar.gz
tdetoys-d230ffe91600f31235f382cf8c0c5738a91101f9.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 094853ca31a9dc5e619b0951953d4dc862a99e25)
Diffstat (limited to 'kteatime/CMakeLists.txt')
-rw-r--r--kteatime/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/kteatime/CMakeLists.txt b/kteatime/CMakeLists.txt
index a512391..22311fd 100644
--- a/kteatime/CMakeLists.txt
+++ b/kteatime/CMakeLists.txt
@@ -41,11 +41,10 @@ tde_install_icons(
##### other data ################################
-install( FILES eventsrc
+tde_create_translated_desktop(
+ SOURCE eventsrc
DESTINATION ${DATA_INSTALL_DIR}/kteatime
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kteatime-eventsrc
)
-install( FILES kteatime.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
-
+tde_create_translated_desktop( kteatime.desktop )