summaryrefslogtreecommitdiffstats
path: root/kteatime/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
commit094853ca31a9dc5e619b0951953d4dc862a99e25 (patch)
tree1d5cf4fca876d27b913dbf3afe5a212a91b2b681 /kteatime/CMakeLists.txt
parentcbaa57c4db0b5723b68ff5e719d8d965b7f34ec2 (diff)
downloadtdetoys-094853ca31a9dc5e619b0951953d4dc862a99e25.tar.gz
tdetoys-094853ca31a9dc5e619b0951953d4dc862a99e25.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kteatime/CMakeLists.txt')
-rw-r--r--kteatime/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/kteatime/CMakeLists.txt b/kteatime/CMakeLists.txt
index a512391..22311fd 100644
--- a/kteatime/CMakeLists.txt
+++ b/kteatime/CMakeLists.txt
@@ -41,11 +41,10 @@ tde_install_icons(
##### other data ################################
-install( FILES eventsrc
+tde_create_translated_desktop(
+ SOURCE eventsrc
DESTINATION ${DATA_INSTALL_DIR}/kteatime
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kteatime-eventsrc
)
-install( FILES kteatime.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
-
+tde_create_translated_desktop( kteatime.desktop )