summaryrefslogtreecommitdiffstats
path: root/kweather/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
commit094853ca31a9dc5e619b0951953d4dc862a99e25 (patch)
tree1d5cf4fca876d27b913dbf3afe5a212a91b2b681 /kweather/CMakeLists.txt
parentcbaa57c4db0b5723b68ff5e719d8d965b7f34ec2 (diff)
downloadtdetoys-094853ca31a9dc5e619b0951953d4dc862a99e25.tar.gz
tdetoys-094853ca31a9dc5e619b0951953d4dc862a99e25.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kweather/CMakeLists.txt')
-rw-r--r--kweather/CMakeLists.txt20
1 files changed, 14 insertions, 6 deletions
diff --git a/kweather/CMakeLists.txt b/kweather/CMakeLists.txt
index bddf208..c4c7f44 100644
--- a/kweather/CMakeLists.txt
+++ b/kweather/CMakeLists.txt
@@ -117,23 +117,31 @@ tde_install_icons( kweather )
##### other data ################################
-install( FILES weather_stations.desktop
+tde_create_translated_desktop(
+ SOURCE weather_stations.desktop
+ KEYWORDS name
DESTINATION ${DATA_INSTALL_DIR}/kweatherservice
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kweather-stations
)
install( FILES stations.dat
DESTINATION ${DATA_INSTALL_DIR}/kweatherservice
)
-install( FILES kweather.desktop
+tde_create_translated_desktop(
+ SOURCE kweather.desktop
DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kweather-desktops
)
-install(
- FILES
+foreach( _service
kweatherservice.desktop
kcmweather.desktop
kcmweatherservice.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}
)
-
+ tde_create_translated_desktop(
+ SOURCE ${_service}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kweather-desktops
+ )
+endforeach()