summaryrefslogtreecommitdiffstats
path: root/kworldwatch/maps/depths/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-14 15:26:41 +0200
commit094853ca31a9dc5e619b0951953d4dc862a99e25 (patch)
tree1d5cf4fca876d27b913dbf3afe5a212a91b2b681 /kworldwatch/maps/depths/CMakeLists.txt
parentcbaa57c4db0b5723b68ff5e719d8d965b7f34ec2 (diff)
downloadtdetoys-094853ca31a9dc5e619b0951953d4dc862a99e25.tar.gz
tdetoys-094853ca31a9dc5e619b0951953d4dc862a99e25.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kworldwatch/maps/depths/CMakeLists.txt')
-rw-r--r--kworldwatch/maps/depths/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/kworldwatch/maps/depths/CMakeLists.txt b/kworldwatch/maps/depths/CMakeLists.txt
index 44405bc..2d3d0c5 100644
--- a/kworldwatch/maps/depths/CMakeLists.txt
+++ b/kworldwatch/maps/depths/CMakeLists.txt
@@ -9,8 +9,15 @@
#
#################################################
-install( FILES depths.desktop 400.jpg 800.jpg
+install(
+ FILES
+ 400.jpg 800.jpg
DESTINATION
${DATA_INSTALL_DIR}/kworldclock/maps/depths
)
+tde_create_translated_desktop(
+ SOURCE depths.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kworldclock/maps/depths
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kworldwatch-maps
+)