summaryrefslogtreecommitdiffstats
path: root/kteatime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kteatime/Makefile.am')
-rw-r--r--kteatime/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/kteatime/Makefile.am b/kteatime/Makefile.am
new file mode 100644
index 0000000..82ebf40
--- /dev/null
+++ b/kteatime/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES= $(all_includes)
+
+bin_PROGRAMS = kteatime
+
+kteatime_SOURCES = main.cpp toplevel.cpp tealist.cpp timeedit.cpp
+
+kteatime_METASOURCES = AUTO
+kteatime_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+# LIB_KIO needed for KNotifyDialog
+kteatime_LDADD = $(LIB_KDEUI) $(LIB_KIO)
+
+KDE_ICON = kteatime
+
+KDE_OPTIONS = nofinal
+
+appsdata_DATA = eventsrc
+appsdatadir = $(kde_datadir)/kteatime
+
+kteatimeicondir = $(kde_datadir)/kteatime/icons
+kteatimeicon_ICON = AUTO
+
+messages:
+ $(XGETTEXT) $(kteatime_SOURCES) -o $(podir)/kteatime.pot
+
+xdg_apps_DATA = kteatime.desktop