summaryrefslogtreecommitdiffstats
path: root/khexedit/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-24 15:49:49 +0200
commita1066b66a7b397f1cdac40d6970b9640184fe8f6 (patch)
tree023614a603e30a1f7a3ae99c3bbc366fcb4b2178 /khexedit/CMakeLists.txt
parent2f27665e4d477b9016dc38bf4d83945a371f9c0d (diff)
downloadtdeutils-a1066b66a7b397f1cdac40d6970b9640184fe8f6.tar.gz
tdeutils-a1066b66a7b397f1cdac40d6970b9640184fe8f6.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 296306a273438f476ab2266d1c03616de1fd5ef7)
Diffstat (limited to 'khexedit/CMakeLists.txt')
-rw-r--r--khexedit/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/khexedit/CMakeLists.txt b/khexedit/CMakeLists.txt
index 89323d2..661218b 100644
--- a/khexedit/CMakeLists.txt
+++ b/khexedit/CMakeLists.txt
@@ -55,7 +55,7 @@ install( FILES khexeditui.rc
DESTINATION ${DATA_INSTALL_DIR}/khexedit
)
-install( FILES khexedit.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
+tde_create_translated_desktop(
+ SOURCE khexedit.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/khexedit-desktops
)
-